Персональный сайт Александра Тауениса » Aircrack-ng 1.1 + Debian 7.0

Aircrack-ng 1.1 + Debian 7.0

Существует такой пакет программ — «AirCrack-NG», предназначенный для взлома паролей WiFi-сетей, а так же «подслушивания» передаваемых по ним данных. Набор хакера, короче говоря. При установке её в последнюю версию дистрибутива Дебиан, версию 7.0 «Wheezy», которая ещё в стадии тестирования, возможны некоторые трудности. А конкретно эти:

Во первых, её нет в репозисториях. Приходится устанавливать из исходников. Но это не проблема. Проблема в следующем: невозможно скомпилировать. Make ругается на некие неиспользуемые переменные (linux.c:1352:15: error: variable ‘unused’ set but not used), а затем радостно заставляет Вас поперхнуться кофе, которое Вы уже налили, ожидая длительный процесс компиляции. Выскакивает некая ошибка №2. Процесс сорван. Чтобы это исправить, необходимо исправить строку №70 в файле «common.mak» на следующее:
CFLAGS          ?= -g -W -Wall -O3

После этого прекрасно идёт компиляция, а затем и установка. Кстати говоря, устанавливать нужно при помощи «sudo checkinstall -D», а не «sudo make install». Почему? По качану!
После этого возможны ошибки чекинсталла на конфликт с пакетом «iw», но на деле всё работает.

Обновление от 20 июля: Есть сложности! Из-за конфликта этих пакетов система отказывается обновляться. Вот такие дела. iw нельзя удалять, поскольку он отвечает за «вафлю». Поэтому, приходится удалять пакет aircrack-ng, обновлять пакеты, и затем ставить «Аиркряк» опять. Жду-не дождусь появления пропатченного Aircrack-NG в репозисториях…

Обновление от 29 октября: Aircrack-NG засветился на репозисториях Дебиан! И хотя через apt-get install его не установить, можно скачать deb-пакет (выбирайте архитектуру). Устанавливается и работает прекрасно.



Поделиться в соцсеть


Оставить комментарий

:D :) ;) :( :o :shock: :? Больше смайлов »

Защита от спама * Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.